Unable to get my button showing up or working

Anybody have an idea Why my button won’t work?

I’ve got a suspicion right now -

im pretty sure the indent on buttons in the screens.yaml file is supposed to be like this, but whenever i save it auto corrects into this:

tbh not very tech savvy so I dont know how one would fix this.

  • :browser: : :firefox:
  • :computer: :windows:
    narrat version 3.7.0
  • :grey_question: What steps did you already try to fix it, if any?
    so right now I’ve tried all the different options for Buttons on the docs.
  • I can get the button text to show up, but it’s not interactable even if I activate its tag or set the button to true or enable it in the script.
  • i cant for the life of me get the image to show up - the image i use is id’d in the screens.yaml. (strangely enough, ive tried to use my placeholder black image and that one worked? somehow? although i cant recreate it anymore)

its either that or i missed a step where you have to define the action further. I’ve already tried “action: run_label” with “label: labelName” which didn’t do it either.
rn the action just says the name of the label

:gear: Logs or screenshots of the issue:

any help would be appreciated!!

Have you looked if it isn’t just not finding the image? Like if there’s a network error in the browser devtools showing it couldn’t load the image, especially can happen if there were caps in the file name at some point and it’s been renamed… same thing for the label, if it isn’t spelled the same way as in the script

Also if you send the full files for screens/buttons it might be easier to see.

there’s no errors showing up - I’ll send you the files, I’m pretty stumped still