Have trouble installing narrat

i installed node.js and VS Code, opened the windows PowerShell in the folder, but after i type ‘npm create narrat@latest’ and enter, it shows ‘The “npm” item cannot be recognized as the name of a cmdlet, function, script file, or runnable program’ (i translated it from my non-English system, may not be completely accurate). and i looked at the instruction video which shows the exactly thing i did in this step and succussed, so i don’t know where i did wrong?

:computer: windows:

Did you try restarting after installing node.js? Maybe the pc didn’t know about the command yet… If node.js is installed npm should exist. Or try installing node again

thank you! i reinstalled it and it worked. but now i’m stuck on another step); after “npm install” it always stops in the middle like this, unlike the construction video where it smoothly goes into next step…

I’m not sure why it’s doing this but I found this when looking it up.

Some of the replies say it’s a bug with a specific version of node/npm (though I’m not sure why no one else using narrat got this) and say to do this:

“Same here. node 18.12.1 npm 8.19.2. the only solution was to downgrade to npm v6 npm install -g npm@6 :sob:

So maybe try npm install -g npm@6 and then restart the terminal and see if it works

Or also as this comment says, maybe you just need to wait longer:
image

thank you! i tried the downgrade code and restarted it, waited a few hours longer but it eventually worked! :joy_cat:

1 Like